Results 1 to 7 of 7

Thread: 1983 gs550l

  1. #1
    Join Date
    Jun 2017
    Location
    Asheboro NC
    Posts
    8

    Default 1983 gs550l

    Hello I just got a 1983 GS550, i founout it has no spark to any plug, useing a test light i get constant power on + side of both coils and on off signal from the other. I preformed the resistance checks and coils and pickups bothe test good, ignitor not so much, qustion is will it still flicker at the coil if the ignitor bad? Thanks

  2. #2
    Join Date
    Aug 2010
    Location
    Sebago,Maine
    Posts
    7,511

    Default

    "qustion is will it still flicker at the coil if the ignitor bad? "

    I would imagine so. Unfortunately, 550 ignitors seem trouble prone,and to add to the misery,your 550 came with ignition advance built into ignitor (rather than a mechanical advance) - finding a afforable replacement will be difficult.

    Sounds like you have done the right checks, but doublecheck the wiring from ignitor to ignition coils.Is your battery decent?
    1981 gs650L

    "We are all born ignorant, but you have to work hard to stay stupid" Ben Franklin

  3. #3
    Join Date
    Jun 2017
    Location
    Asheboro NC
    Posts
    8

    Default

    The batter spins engine good, shows 11.5 volts at ignitor an 10.6 at coils

  4. #4
    Join Date
    Jun 2017
    Location
    Asheboro NC
    Posts
    8

    Default

    I keep reading that boyer bransden makes a unit for the 16 valve gs550l engine dose anyone know what kit to use the GS250-500 kit uses a 3 bolt pick up plate, mine is a 2 bolt? GSX kit mabe?

  5. #5
    Join Date
    Aug 2010
    Location
    Sebago,Maine
    Posts
    7,511

    Default

    Their micro digital system seems likely to work... but you might have to switch to their ignition coils and redrill mounting plate.Hopefully, our English members will chime in with their thoughts.
    1981 gs650L

    "We are all born ignorant, but you have to work hard to stay stupid" Ben Franklin

  6. #6
    Join Date
    Jun 2017
    Location
    Asheboro NC
    Posts
    8

    Default

    Update, today did some more testing, using a 6 amp bat charger i got the coils to spark, but weak even after running a hot wire to the coils, ignitor did fail resistance tests but is signaling spark?

  7. #7
    Join Date
    Aug 2010
    Location
    Sebago,Maine
    Posts
    7,511

    Default

    Some spark sounds promising. Unscrew all spark plug caps and cut back each plug wire about 1/4 inch and reattach plug caps. Could be corrosion in the plug cap/resistor area.
    1981 gs650L

    "We are all born ignorant, but you have to work hard to stay stupid" Ben Franklin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •